USB and external drives not mounting

USB and external drives not mounting

Postby glasiad » 01 Oct 2014, 19:00

I've run into a problem trying to mount usb flash drives and external hard drives. When I plug one of them is I get a text box:

Could not display "/media/A51E-B349".

The location is not a folder.

It's not the media because they work fine on other systems.
It's not this hard ware because they mount fine on this machine on another linux system I have installed.
It's not a problem with all installations of Point because I have the same updated installation on another box and it mounts the same drives without issue.

So I'm at a loss. Any ideas?
glasiad
 
Posts: 10
Joined: 12 Jan 2014, 15:42

Re: USB and external drives not mounting

Postby glasiad » 01 Oct 2014, 20:11

I had a epiphany - maybe it's a permission issue.

So I entered the command -

sudo chmod 777 /media

and the problem is solved.

How and why I lost permissions on /media is a mystery!

Hope that helps someone else :)
glasiad
 
Posts: 10
Joined: 12 Jan 2014, 15:42

Re: USB and external drives not mounting

Postby Maroman » 04 Oct 2014, 12:57

it seems for me that the problem is a little different. it looks as if you have wrong mime settings (application is trying to open your external disc as a folder). pity you don't write if disc was mounted or not (as a matter of fact from your post I do not see if it's mounted or not. ).

please check the file $HOME/.local/share/applications/mimeapps.list. verify your associations. the problem might be here.

I do not now how mode of your /media directory could be changed. and by the way is 755 not 777 (you also didn't show existing settings).

sometimes flash doesn't mount automatically (but can be seen). I tested some of mine -- pqi, toshiba and kingstons. all were seen if you enter
Code: Select all
sudo blkid -o list

but only pqi was not mounted.

Image Image Image Image

cheers,
ride my bike,
User avatar
Maroman
 
Posts: 369
Joined: 02 Jun 2013, 09:17
Location: Warsaw Metropolitan Area, Poland


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron