Brother printer-scanner DCP-7060D

Brother printer-scanner DCP-7060D

Postby snowdust » 30 Dec 2014, 20:11

Season's Greetings,
Installed PL3.0b3 MATE 64bit edition on the following system:

root@karibou:/home/snowdust# inxi -Fxxx
System: Host: karibou Kernel: 3.16.0-4-amd64 x86_64 (64 bit, gcc: 4.8.3) Desktop: N/A Distro: PointLinux 3.0b3 jessie
Machine: Mobo: Acer model: Veriton X275 serial: U01U122601434 Bios: Acer version: P01-C2 date: 02/15/2012
CPU: Dual core Pentium CPU E6600 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 12235.9
Clock Speeds: 1: 1603.00 MHz 2: 1603.00 MHz
Graphics: Card: Intel 4 Series Chipset Integrated Graphics Controller bus-ID: 00:02.0 drivers: intel (unloaded: fbdev,vesa) tty size: 80x24 Advanced Data: N/A for root
Audio: Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: k3.16.0-4-amd64
Network: Card: Broadcom NetXtreme BCM57760 Gigabit Ethernet PCIe driver: tg3 ver: 3.137 bus-ID: 01:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: d0:27:88:d1:8e:a3
Drives: HDD Total Size: 500.1GB (0.8% used) 1: id: /dev/sda model: ST3500413AS size: 500.1GB serial: Z2AVKN1Y temp: 47C
Partition: ID: / size: 223G used: 3.6G (2%) fs: ext4 ID: /home size: 225G used: 83M (1%) fs: ext4
ID: swap-1 size: 12.00GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 49.0C mobo: 24.0C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 147 Uptime: 11 min Memory: 491.1/3931.3MB Runlevel: 5 Gcc sys: 4.9.1 alt: 4.8 Client: Shell inxi: 1.8.4

I have a multi-functional Brother printer-scanner model DCP-7060D. Note that the company provides 32-bit printer drivers only for this model. On the other hand 32-bit and 64-bit scanner drivers are available. In order to be able to print documents I installed lib32ncurses5 + 32bit lpr and cupswrapper drivers and the printer works just fine. I also installed the 64-bit scanner driver and Xsane to test the scanner and got the following error message:
Failed to open device 'brother4:bus1;dev1'; Invalid argument.

I ran other debian(jessie) based distros and lately got the same error message. Xsane used to work fine. Could latest changes to Jessie have caused Xsane to stop working properly?
Have other members experienced this situation and found a solution? Thanks for sharing.
Posts: 4
Joined: 18 Jan 2014, 22:07
Location: Montreal CANADA

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests