Removing "Computer" and "Home" icons from desktop

Removing "Computer" and "Home" icons from desktop

Postby jagodanbg » 01 Sep 2014, 12:49

How to remove "Computer" and "Home" icons from desktop!?

Thanx
jagodanbg
 
Posts: 4
Joined: 31 Aug 2014, 18:56

Re: Removing "Computer" and "Home" icons from desktop

Postby Maroman » 01 Sep 2014, 12:59

menu > system tools > configuration editor > apps > caja > desktop
you can check or uncheck these and similar options,

cheers,
ride my bike,
User avatar
Maroman
 
Posts: 369
Joined: 02 Jun 2013, 09:17
Location: Warsaw Metropolitan Area, Poland

Re: Removing "Computer" and "Home" icons from desktop

Postby jagodanbg » 01 Sep 2014, 13:26

@Maroman

"Computer" for example is unchecked, but is still on the descktop?! :(
jagodanbg
 
Posts: 4
Joined: 31 Aug 2014, 18:56

Re: Removing "Computer" and "Home" icons from desktop

Postby Maroman » 01 Sep 2014, 14:57

jagodanbg wrote:"Computer" for example is unchecked, but is still on the descktop?! :(

interesting. nobody's perfect.

as a matter of fact it works as a trigger and action is (in my case) almost immediate. try to check and uncheck the box. I hope, that sooner or later, if it's unchecked, the icon disappears.

cheers,
ride my bike,
User avatar
Maroman
 
Posts: 369
Joined: 02 Jun 2013, 09:17
Location: Warsaw Metropolitan Area, Poland

Re: Removing "Computer" and "Home" icons from desktop

Postby jagodanbg » 01 Sep 2014, 17:27

I tried that already but nothing happend
jagodanbg
 
Posts: 4
Joined: 31 Aug 2014, 18:56

Re: Removing "Computer" and "Home" icons from desktop

Postby Maroman » 01 Sep 2014, 18:35

the settings for desktop icons seems to be in this file ~/.mateconf/apps/caja/desktop/%mateconf.xml. check it (you can also manually change this file). I have
Code: Select all
<?xml version="1.0"?>
<mateconf>
   <entry name="computer_icon_visible" mtime="1409583146" type="bool" value="false"/>
   <entry name="volumes_visible" mtime="1407135022" type="bool" value="false"/>
   <entry name="trash_icon_visible" mtime="1406470454" type="bool" value="false"/>
   <entry name="home_icon_visible" mtime="1407045513" type="bool" value="false"/>
</mateconf>

to have the icon on the desktop I can change false to true. settings are valid after desktop restart.

you can also watch some instruction on changing mate settings. I don't want to go into details but storing system configuration settings is different in mate 1.4 and 1.6 and next. you can read mate wiki but it's very limited, for example on mate-conf there are only a few lines.

try to set the boolean values manually as needed and restart.

cheers,
ride my bike,
User avatar
Maroman
 
Posts: 369
Joined: 02 Jun 2013, 09:17
Location: Warsaw Metropolitan Area, Poland


Return to MATE Desktop

Who is online

Users browsing this forum: No registered users and 1 guest

cron