Page 1 of 1

GRUB could not be configured.

PostPosted: 29 Jun 2013, 19:34
by SophistiHick
Hey y'all. First of all let me say I really like the work that has been done on this distro, the combination of Debian stability plus MATE simplicity kind of reminds me of a VW Beetle, simply reliable. Now for the problem. When I installed Point Linux on my laptop for the first time, everything went smoothly (expect for a misunderstanding with defining the / partition, right click, then set as /, duh :). But when the installation finished, I received an error, "GRUB could not be configured. You must configure grub manually." My reaction was, "Hmm, well whatever, it'll still boot." And of course it didn't. When I rebooted I received a GRUB error, "error: file not found" and was entered into GRUB rescue mode, having no idea where to go from there and after some fruitless googling, I decided to reinstall. I remembered having told grub to install in the same partition as root (sda1). So I made a separate grub partition, 200MB of unallocated space and told GRUB to install to that. But when the installation finished, I got the same error. So I downloaded Super GRUB2 Disk, which successfully found Point Linux, but no grub files. I tried booting into Point Linux from the Super GRUB2 Disk, but after the normal startup process (starting/switching on things) all I got was a black screen. As far as I could tell there wasn't any way to install grub from the Super GRUB2 Disk, so I'm going to download boot-recovery-disk as soon as I can get near high speed internet (536MB on dial-up would take several years). Hope someone can make some sense out the preceding babble :) and find a solution, if not I'll update when I get boot-recovery-disk. Thanks in advance.

Super GRUB2 Disk: http://www.supergrubdisk.org/category/d ... sk-stable/

Boot-Recovery-Disk: http://sourceforge.net/p/boot-repair-cd/home/Home/

Re: GRUB could not be configured.

PostPosted: 30 Jun 2013, 16:57
by Maroman
probably U should install grub on the disk not partition (sda instead sda1).
you can try to reinstall grub. please look at this manual http://semplice-linux.org/doku/semplice:users:linstaller:bootreinstall. however it is for different debian distro but it works for all distros.
have you tried other distro? try for example with ubuntu or mint (look at hints). if it works it should work for point (of course you can keep more distros and/or windows/mac with one convinient grub).
what is the firmware of your computer?

good luck. cheers,

Re: GRUB could not be configured.

PostPosted: 05 Jul 2013, 02:34
by SophistiHick
It's alive! It's alive! It's alive! :D . After trying the boot-recovery-disk, which is based on Lubuntu interestingly enough, and getting no results, I decided to wipe the CD and reburn the ISO. And it worked! :D YAY! The only hitch is that it keeps freezing up and I have to manually shut it down :( . My laptop is pretty old, almost 13 years I think, and it heats up pretty easily so I guess that could be the problem. Thanks Maroman for your suggestions, I tried installing to sda and I was going to follow the instruction in the link, after the reburn but, fortunately, it wasn't necessary. :) .

Re: GRUB could not be configured.

PostPosted: 04 Oct 2013, 11:45
by TNFrank
You really have to watch where you install GRUB. I know because I've ran into this same "problem" before I learned what to do. The Distro goes on/in sda1 but GRUB will be pointed to sda. I once installed both on sda1 and as you can see, it won't work properly. Anyway, hope this helps.

Re: GRUB could not be configured.

PostPosted: 05 Oct 2013, 06:05
by Maroman
Grub is installed in three or two pieces (depends on computer firmware). main part is obviously on Linux partition. but pointing mbr (or sda) you only place the first part of it in a fragment of boot record to start the grub properly.
if you use different bootloader (for example from windows), then pointer to linux should be at distro's partition. and all this causes the mess.

cheers,