[SOLVED] Funny Clock Save On Shutdown

[SOLVED] Funny Clock Save On Shutdown

Postby ausmuso » 10 Sep 2014, 02:18

On shutdown my Point Linux sets the hardware clock in an unusual way.
Debian normally expects the hardware clock to be on UTC. On bootup it applies an offset depending on the locale (in my case UTC+10) to work out the local time on the desktop. Whilst running it keeps synchronising the system clock with NTP and on shutdown it saves the corrected time, in UTC format, back to the hardware clock.

Similar things seem to happen in Point Linux except on shutdown. Then Point Linux sets the hardware clock not to UTC but to the local time the session ended.

This doesn't matter as long as Point Linux is the only distro on your machine. If you also have one or more other distros on your machine - which expect your hardware clock to be on UTC - they get confused time-wise.

There must be a configuration file somewhere in the bootup/shutdown sequence I can tweak to make Point Linux behave more "Debian-like", but I haven't been able to find it so far.

Any suggestions?
Last edited by ausmuso on 12 Sep 2014, 02:07, edited 1 time in total.
Linux from 1997 (Slackware, Caldera, Red Hat, Mandrake, (Open)SuSE, Poppy, Ubuntu, CentOS, Mint 13 & LMDE, Crunchbang)

If at first you don't succeed . . . . . . . .
. . . . . . . skydiving is not for you!
User avatar
ausmuso
 
Posts: 11
Joined: 05 Sep 2014, 08:33
Location: Blue Mountains, Australia

Re: Funny Clock Save On Shutdown?

Postby Maroman » 10 Sep 2014, 05:01

firstly check the file /etc/adjtime. the last line is set either UTC or LOCAL.
check also if ntp service is on (installed application and set in services settings - menu > systems > administration > services). if you need more please read Debian wiki.

cheers,
ride my bike,
User avatar
Maroman
 
Posts: 369
Joined: 02 Jun 2013, 09:17
Location: Warsaw Metropolitan Area, Poland

Re: Funny Clock Save On Shutdown?

Postby ausmuso » 11 Sep 2014, 02:55

Maroman wrote:firstly check the file /etc/adjtime. the last line is set either UTC or LOCAL.
check also if ntp service is on (installed application and set in services settings - menu > systems > administration > services). if you need more please read Debian wiki.

Thanks for your help, Maroman!
/etc/adjtime shows UTC, ntp service is on and working correctly.
I'm sure I'll find the "funny" in due course, it's not urgent and I'm not really worried about it.
Anyway, back to double bass practice first, we've got a performance on this Sunday.
Cheers!
Linux from 1997 (Slackware, Caldera, Red Hat, Mandrake, (Open)SuSE, Poppy, Ubuntu, CentOS, Mint 13 & LMDE, Crunchbang)

If at first you don't succeed . . . . . . . .
. . . . . . . skydiving is not for you!
User avatar
ausmuso
 
Posts: 11
Joined: 05 Sep 2014, 08:33
Location: Blue Mountains, Australia

Re: [SOLVED] Funny Clock Save On Shutdown

Postby ausmuso » 12 Sep 2014, 02:09

I got tired of looking through scripts so I simply reinstalled my Point Linux from scratch. And blow me down, the "funny" is no longer there. Clock and NTP behave perfectly all the time.

Problem solved. Only . . . now I'll never know what caused it in the first place :)
Linux from 1997 (Slackware, Caldera, Red Hat, Mandrake, (Open)SuSE, Poppy, Ubuntu, CentOS, Mint 13 & LMDE, Crunchbang)

If at first you don't succeed . . . . . . . .
. . . . . . . skydiving is not for you!
User avatar
ausmuso
 
Posts: 11
Joined: 05 Sep 2014, 08:33
Location: Blue Mountains, Australia


Return to Other Topics

Who is online

Users browsing this forum: No registered users and 1 guest

cron