Page 1 of 1

Can not login after updates?

PostPosted: 14 Sep 2014, 15:21
by CuriousGuy
First off I am basically a total noob. I installed Point Linux 2.3.1 last night. All went well. It was strange that the LiveDVD recognized my wireless network but could not tell I was also connected via a wire. But not biggie. I installed and all was well. It told me I had updates so I ran those. When it asked did I want to install only safe updates (not install new or remove old) I clicked "No." That worked fine and I was asked to reboot. I did and all was OK. Then it said I had more updates. I ran those and that is when I encountered a problem.

I can no longer log-in to my system. The system starts and gets to the login screen. I type in my password and the screen goes blank and shows something like this:

[FAIL] start (something here I can't really see because screen flashes too quickly)... plymouth ... failed!

Basically it flashes for what seems like 1/2 second then goes back to the log in screen. I re-type the password and get the same thing. I know it is the correct password because if I type the wrong password (or just hit Enter or click "Login") it tells me the password is incorrect. But when I type the correct one I can not log in.

So I thought I did something wrong so I re-installed Point Linux this morning. I followed the same steps and am at the same point again. So apparently there is something wrong with the updates (a conflict or something?) or I am updating incorrectly. I also noticed when I ran updates via the Terminal (sudo apt-get update / sudo apt-get upgrade) that there are a number of packages being "Held Back" (or something like that). Should I update the system differently?

Any help on this would be most useful. I am not opposed to reinstalling again (I haven't edited this machine and do not have any personal items on here). But I like what I saw via the LiveDVD and would really like to give this a go.

Again, I am basically a total noob so any help you can give is most appreciated. Also, if possible, please explain in easiest to understand (and follow) steps.

Thank you again.

Re: Can not login after updates?

PostPosted: 14 Sep 2014, 19:32
by CuriousGuy
OK. I'm not sure what is different but I have moved on. I decided to just do a re-install. So I booted into the LiveDVD and used gparted to delete the existing partitions. Then I re-installed. This time I chose to not tick the entry for using backports (which I had previously done both times).

When installation was complete I rebooted and did not update. Instead I went to Services and un-ticked Plymouth. Then I rebooted. Then I went to the terminal and ran "sudo apt-get dist-update." I didn't know about this until a little (OK, a lot) of Googling. There were warnings about not doing it unless necessary but I figured I was just trying anything. Anyway, all updates installed and then I rebooted again. Logged back in and all is well. I haven't turned the Plymouth option back on because I don't know if that is where the problem was.

I'm going to mark this thread as solved. I don't know if this actually is solved because I don't know what happened with the two previous attempts. But I'm running and able to update and log in so all is good for me.

Now I'm onto trying to figure out Linux and how to install other apps. The next step is trying to figure out the pepperflashplugin-non-free thingy that my machine keeps telling me it can't find.

Anyway, just figured I would post an update and let anyone else who might encounter the same problem I had what I ended up doing.

Re: Can not login after updates?

PostPosted: 15 Sep 2014, 01:41
by CuriousGuy
Never mind on the "solved" post. It seemed to be working just fine for most of the afternoon. Then I locked the screen while I took the SO to the store. When we got back I logged back in but system was unresponsive to commands (couldn't open a Terminal, couldn't open a browser). It's an older computer (Core2Duo) so I figured a reboot might fix the issue. As soon as I did that (that part of the system was working) I encountered the exact same problem again. Tried different things and still no luck. I'm not sure what is causing the issue but if anyone has any idea's I would love to try.

Thanks again and keep your fingers crossed.

Re: Can not login after updates?

PostPosted: 15 Sep 2014, 15:33
by GB Jim
I don't think it is Point's hardware requirements. I run Point on an old 2001 windows XP computer. It has a single 1.6 Ghz processor, a thirty gig hard drive and I updated to one gig of memory from 256 meg. The processor maxes out to 100%, making it a bit slower, but it works.

I would first do "sudo apt-get update" after booting up, then " sudo apt-get upgrade" first before trying "sudo apt-get dist-update".

Also if only you use the computer and don't have security issues try auto login when you install or go to System > Administration > users and group and change to auto login. You could also trying setting up another account with admin rights to see if you can log into that and make changes if you cannot get into your original account. Then do your reboot. You can always set it to Password asked at Login later.