Page 1 of 1

Can't mount external Hard Drive

PostPosted: 05 Mar 2013, 06:36
by cpatrick08
When I try to mount my 500GB Western Digital Passport external hard drive I get following error message

Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

Re: Can't mount external Hard Drive

PostPosted: 05 Mar 2013, 09:08
by Pry
Hi, cpatrick08!
That's a Debian bug #631504.

The quick solution is to comment the /dev/usb0 line in your /etc/fstab file that usually looks like:
/dev/sdX1 /media/usb0 auto rw,user,noauto 0 0

Where X is the last letter of your device. That did the job for me!
This solution is described here.

cpatrick08, did you use USB stick for installation?

Re: Can't mount external Hard Drive

PostPosted: 05 Mar 2013, 21:47
by cpatrick08
Pry wrote:Hi, cpatrick08!
That's a Debian bug #631504.

The quick solution is to comment the /dev/usb0 line in your /etc/fstab file that usually looks like:
/dev/sdX1 /media/usb0 auto rw,user,noauto 0 0

Where X is the last letter of your device. That did the job for me!
This solution is described here.

cpatrick08, did you use USB stick for installation?

yes I did use USB stick for installation

Re: Can't mount external Hard Drive

PostPosted: 06 Mar 2013, 04:34
by Pry
cpatrick08, have my solution solved your problem?

Re: Can't mount external Hard Drive

PostPosted: 07 Mar 2013, 16:32
by just
i have had the same identical problem - on freshly installed Point Linux it wasn't possible to mount external usb devices.

i've installed the system from usb stick. after your suggestion, i've opened /etc/fstab, and - surprise! - there was an /dev/sdc1 device added by installer in it (commented out by me):

#--/dev/sdc1 /media/usb0 auto rw,user,noauto 0 0

needless to say, commenting it out has solved the problem. external usb devices are mounted without any trouble now. thanks for the tip, Pry. and for the excellent distro!

regards

Re: Can't mount external Hard Drive

PostPosted: 22 Mar 2014, 09:36
by tomsmith0007
Hiiii
i am great fan of your Forums , i am regularly follow your post , every time you give me very
useful information that help me lot , i think you r right ..................
...................................................
wel come to the unix forum site here u can find ans of you are question
you was asking for the app of unix that was the great
i cant answerof you are question? but if u want some batter answer plz visit
.

.........................................................................................

LINUX