Page 1 of 1

No video with supported format and MIME type found.

PostPosted: 07 Jan 2015, 19:58
by GB Jim
When I try to watch certain You Tube videos with Firefox I get this instead of the video playing:

"No video with supported format and MIME type found." There is also a big X in the middle of the screen.

I cannot download the video, and the link won't play in any of my video player. (VLC, Totem. or SMPlayer). I can switch to Chromium and see the video, but I prefer Firefox.

As far as I can find it has something to do with a .htacess file and the apache server. I can't figure out how to fix it though. I have read up on it, and not gotten anywhere. Anyone else had this problem? Anyone have any ideas?



Solvved: No video with supported format and MIME type found.

PostPosted: 14 Jan 2015, 18:36
by GB Jim
I got it on my own. I installed some codecs (libavcodec) and then had another message of " no url found". I took off add-on that was a blocker and now it works. Not sure that will help anyone else, but for now I have it working in Mozilla browsers.

Re: No video with supported format and MIME type found.

PostPosted: 27 Jan 2015, 23:46
by GB Jim
I have done some more research on the Internet on this subject and there is a lot of bad information and a little good info. Firefox does not support MP4 and HTML5 natively. Look if you have "gatling" installed. If not install it from the repository. Then search for htaccess. You should find a file called "README.htaccess'. Open that as root with your text editor (pluma or gedit). Do this by "sudo pluma". Then add this to the README.htaccess file.

AddType video/mp4 mp4 m4v
AddType audio/mp4 m4a
AddType video/ogg ogv
AddType audio/ogg ogg oga
AddType video/webm webm

Then save. Make sure your Firefox is up to date and you should be able to play Youtube MP4 and HTML5 files in Firefox.

Re: No video with supported format and MIME type found.

PostPosted: 28 Jan 2015, 06:25
by Maroman
Hi Jim,

to download sth from yt I'm using easy youtube video downloader express (look here). you can add this functionality to firefox adding adds-on (all yt downloaders for chrome were removed). due to Internet limitations (I'm using cellular) I prefare downloading and watching in vlc (once downloaded, watching forever ). moreover I'm blocking flash not to start automatically (limits!!).

but your first problem might be of different nature. to see yt video you need only flash. check your browser. in ff there is (go to adds-on plugins) shockwave flash.

you can also change yt options to set html5 viewer (flash is default). check

must say I do not understand
GB Jim wrote:Firefox does not support MP4 and HTML5 natively.

it's both false and truth. every browser natively supports html. there are problems with supporting some functionalities (browsers do not support html in 100%). html5 is at the moment recommendation, standard to be. there are multimedia functions in it. and there is another problem how to realize new functionalities. it's browser depend function in this sense that every browser can treat mp4 files in different way. on html5 multimedia functions you can see here for example.

please also read the newest info on yt


Re: No video with supported format and MIME type found.

PostPosted: 18 Feb 2015, 01:31
by GB Jim
Hi Maroman.
I am by no means a computer expert, or Linux expert. I also said the information I found was good and bad. At times I cannot figure out what is good or bad. Though I love Linux, I am a Windows convert, so a GUI guy. I can only wish I had your knowledge.

When I first posted here, no one answered. Here is what I had when going to some, but not all Youtube videos. (Taylor Swift's - "Blank Space: was my test video).
I tried a myriad of addons, but could not play the video in my browser or down load it. Here is a sceenshot:

Mime Screenshot.png
Mime Screenshot.png (94.93 KiB) Viewed 10119 times

I tried "about:config" and toggling "media.gstreamer.enabled: from false to true. The only thing the worked was installing Gatling and adding the aforementioned video types to the README.htaccess file. It might not be correct, but it worked on Two Point installations, two Zorin installations, and four more installations I have on USB drives. In other words this solutions has never failed me so far. I only hope this post might help someone else with the problem.

I am not sure why no one here seemed to know about this, as there are many post on the internet about it, but only a few good solutions, none with good directions.

I do appreciate your knowledge and help here in this forum. Any more insight on this would be appreciated.